summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 21 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f40664f..b23f4a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,11 +23,12 @@ cmake_minimum_required( VERSION 2.8 )
include( CheckCXXSourceCompiles )
+
+##### include our cmake modules #################
+
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
-include( ConfigureChecks.cmake )
-
##### install paths setup #######################
@@ -38,6 +39,24 @@ tde_setup_install_path( INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/t
tde_setup_install_path( PKGCONFIG_INSTALL_DIR "${LIB_INSTALL_DIR}/pkgconfig" )
+##### optional stuff ############################
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+
+option( WITH_QT3 "Build TQt interface based on TQt3" ${WITH_ALL_OPTIONS} )
+option( WITH_QT4 "Build TQt interface based on Qt4" OFF )
+
+
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+
+
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+
+
##### tqtinterface sources ######################
add_subdirectory( qtinterface )