summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index 64fbb38..9803386 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -100,8 +100,13 @@ install(
##### tqt tools #################################
configure_file( tmoc.cmake tmoc @ONLY )
-configure_file( tqt-replace.cmake tqt-replace @ONLY )
-configure_file( tqt-replace-stream.cmake tqt-replace-stream @ONLY )
+if ( NOT HAVE_REAL_TQT )
+ configure_file( tqt-replace.cmake tqt-replace @ONLY )
+ configure_file( tqt-replace-stream.cmake tqt-replace-stream @ONLY )
+else ()
+ configure_file( tqt-replace-tqt3.cmake tqt-replace @ONLY )
+ configure_file( tqt-replace-stream-tqt3.cmake tqt-replace-stream @ONLY )
+endif ()
install( PROGRAMS
moc-tqt uic-tqt mcopidl-tqt dcopidl-tqt dcopidlng-tqt