summaryrefslogtreecommitdiffstats
path: root/src/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/config/CMakeLists.txt')
-rw-r--r--src/config/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/config/CMakeLists.txt b/src/config/CMakeLists.txt
new file mode 100644
index 0000000..2514cf9
--- /dev/null
+++ b/src/config/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+
+##### twin_SUSE2_config (kpart)
+
+tde_add_kpart( twin_SUSE2_config AUTOMOC
+
+ SOURCES
+ config.cpp
+ configdialog.ui
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)