summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-12-20 08:43:52 -0800
committerPavel Roskin <plroskin@gmail.com>2016-12-20 13:07:48 -0800
commit0e7bc6e1119e076b1e30af0c7c7b5f70fb6aa5bc (patch)
tree4d83dc6a07720282c65a003789465cc8c3c821da /Makefile.am
parent634aa1096f5cd95b9d2b82a6461c8030269bf65e (diff)
downloadxrdp-proprietary-0e7bc6e1119e076b1e30af0c7c7b5f70fb6aa5bc.tar.gz
xrdp-proprietary-0e7bc6e1119e076b1e30af0c7c7b5f70fb6aa5bc.zip
Compile libpainter only if enabled, fix path to libpainter.a
When subpackages are compiled outside the build tree, the build artifacts are placed under top_builddir.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 52ea2e61..a6ddaf1f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,12 @@ else
XRDPVRDIR =
endif
+if XRDP_PAINTER
+PAINTERDIR = libpainter
+else
+PAINTERDIR =
+endif
+
if XRDP_RFXCODEC
RFXCODECDIR = librfxcodec
else
@@ -40,7 +46,6 @@ RFXCODECDIR =
endif
SUBDIRS = \
- libpainter \
common \
vnc \
rdp \
@@ -48,6 +53,7 @@ SUBDIRS = \
mc \
$(NEUTRINORDPDIR) \
libxrdp \
+ $(PAINTERDIR) \
$(RFXCODECDIR) \
xrdp \
sesman \