summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-12-24 14:48:02 -0800
committerjsorg71 <jay.sorg@gmail.com>2017-03-02 21:47:37 -0800
commit24d44def601a7ebae5b79743a9c34ca024997531 (patch)
tree5895afd6db9e06539e7882edc46373ac234489b2 /Makefile.am
parent1c355409a77c897e42723d25e7e361356095efd8 (diff)
downloadxrdp-proprietary-24d44def601a7ebae5b79743a9c34ca024997531.tar.gz
xrdp-proprietary-24d44def601a7ebae5b79743a9c34ca024997531.zip
Add --enable-strict-locations option, describe default in its help text
Rather than guess user's intention based on whether --prefix was specified, use an explicit option to enable strict GNU Coding Standards for installation directories. The default is to use /etc and /var rather than corresponding directories under prefix. Use --enable-strict-locations in "make distcheck", it expects all installed files to be under prefix.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3003129d..c8457c54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
-AM_DISTCHECK_CONFIGURE_FLAGS = --without-systemdsystemunitdir
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --without-systemdsystemunitdir \
+ --enable-strict-locations
EXTRA_DIST = \
COPYING \