summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-11-29 16:25:37 -0800
committerPavel Roskin <plroskin@gmail.com>2016-11-29 16:25:37 -0800
commit06f4f72e28088fe4cc915c0c2b258f1bbfef2c05 (patch)
tree60fd46fbb1087e5fc37411c89c38ae2585eae5cc /common/Makefile.am
parent5fbcaf1655edc3cc9734c4e785902c4ff6c5bf40 (diff)
downloadxrdp-proprietary-06f4f72e28088fe4cc915c0c2b258f1bbfef2c05.tar.gz
xrdp-proprietary-06f4f72e28088fe4cc915c0c2b258f1bbfef2c05.zip
Add -ldl to libcommon link flags if it's needed for dlopen()
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 8305ede4..049e8af9 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -52,4 +52,5 @@ libcommon_la_SOURCES = \
libcommon_la_LIBADD = \
-lcrypto \
-lssl \
- -lpthread
+ -lpthread \
+ $(DLOPEN_LIBS)