summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-11-06 22:36:13 -0800
committerPavel Roskin <plroskin@gmail.com>2016-11-06 22:36:13 -0800
commit1fe368c5b3fa05f287731e57d748afb4556d554f (patch)
treebb92f1ef7027a3663c45969ab90367d17ec56cb2 /common/Makefile.am
parent94901c998942ae80654eb509227bece5bfdd2fb6 (diff)
downloadxrdp-proprietary-1fe368c5b3fa05f287731e57d748afb4556d554f.tar.gz
xrdp-proprietary-1fe368c5b3fa05f287731e57d748afb4556d554f.zip
Install headers used by X11rdp and xorgxrdp
Installing the headers makes it possible to compile xorgxrdp as a separate package, without xrdp sources.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 6d7a58c6..8305ede4 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -6,6 +6,11 @@ endif
EXTRA_DIST = pixman-region.c
+include_HEADERS = \
+ xrdp_client_info.h \
+ xrdp_constants.h \
+ xrdp_rail.h
+
AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
@@ -42,9 +47,6 @@ libcommon_la_SOURCES = \
thread_calls.h \
trans.c \
trans.h \
- xrdp_client_info.h \
- xrdp_constants.h \
- xrdp_rail.h \
$(PIXMAN_SOURCES)
libcommon_la_LIBADD = \