summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2014-06-07 20:15:14 -0700
committerJay Sorg <jay.sorg@gmail.com>2014-06-07 20:15:14 -0700
commit17bbecabd36dce18936e3163cd402f8e800da745 (patch)
treee1b14aad3d8d0d038b68c193de5f8b343572db66 /configure.ac
parent293c404a1229b3c8f07de0b074ac5f28529f945c (diff)
downloadxrdp-proprietary-17bbecabd36dce18936e3163cd402f8e800da745.tar.gz
xrdp-proprietary-17bbecabd36dce18936e3163cd402f8e800da745.zip
chansrv: remove simple sound and load pulse modules
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index d11998f8..c3f95bf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,22 +43,10 @@ AC_ARG_ENABLE(tjpeg, AS_HELP_STRING([--enable-tjpeg],
[Build turbo jpeg module (default: no)]),
[tjpeg=true], [tjpeg=false])
AM_CONDITIONAL(XRDP_TJPEG, [test x$tjpeg = xtrue])
-
-AC_ARG_ENABLE(simplesound, AS_HELP_STRING([--enable-simplesound],
- [Build simple pulse audio interface (default: no)]),
- [simplesound=true], [simplesound=false])
-AM_CONDITIONAL(XRDP_SIMPLESOUND, [test x$simplesound = xtrue])
-
AC_ARG_ENABLE(fuse, AS_HELP_STRING([--enable-fuse],
[Build fuse(clipboard file / drive redir) (default: no)]),
[fuse=true], [fuse=false])
AM_CONDITIONAL(XRDP_FUSE, [test x$fuse = xtrue])
-
-AC_ARG_ENABLE(loadpulsemodules, AS_HELP_STRING([--enable-loadpulsemodules],
- [Build code to load pulse audio modules (default: no)]),
- [loadpulsemodules=true], [loadpulsemodules=false])
-AM_CONDITIONAL(XRDP_LOAD_PULSE_MODULES, [test x$loadpulsemodules = xtrue])
-
AC_ARG_ENABLE(xrdpvr, AS_HELP_STRING([--enable-xrdpvr],
[Build xrdpvr module (default: no)]),
[xrdpvr=true], [xrdpvr=false])
@@ -113,20 +101,6 @@ then
[#define _FILE_OFFSET_BITS 64])
fi
-# checking for libpulse
-if ! test -z "$enable_loadpulsemodules"
-then
- AC_CHECK_HEADER([pulse/util.h], [],
- [AC_MSG_ERROR([please install libpulse-dev or libpulse-devel])])
-fi
-
-# checking for libpulse libpulse-simple
-if ! test -z "$enable_simplesound"
-then
- AC_CHECK_HEADER([pulse/simple.h], [],
- [AC_MSG_ERROR([please install libpulse-dev or libpulse-devel])])
-fi
-
# checking for TurboJPEG
if ! test -z "$enable_tjpeg"
then