summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2018-05-23 22:09:45 -0700
committerjsorg71 <jay.sorg@gmail.com>2018-05-25 22:17:31 -0700
commit349616a35d10eb0821b4784198cc196cf86b8a94 (patch)
treee354f352f1fdc5d497aa10b02493ffa327804938 /configure.ac
parenta1576ccbf736fa862885719856e77e9ceafb266a (diff)
downloadxrdp-proprietary-349616a35d10eb0821b4784198cc196cf86b8a94.tar.gz
xrdp-proprietary-349616a35d10eb0821b4784198cc196cf86b8a94.zip
add ipv6only to configure echo and add configure parameter to xrdp -h output
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5bd0eb92..9fd35942 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,7 @@ AC_ARG_WITH([socketdir],
AC_SUBST([socketdir], [$with_socketdir])
AC_ARG_WITH([systemdsystemunitdir],
- AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files, no to disable]),
[], [
if test "x$linux" = xyes; then
with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
@@ -385,6 +385,7 @@ echo " painter $enable_painter"
echo " pixman $enable_pixman"
echo " fuse $enable_fuse"
echo " ipv6 $enable_ipv6"
+echo " ipv6only $enable_ipv6only"
echo " vsock $enable_vsock"
echo " pam $enable_pam"
echo " kerberos $enable_kerberos"
@@ -396,3 +397,4 @@ echo " exec_prefix $exec_prefix"
echo " libdir $libdir"
echo " bindir $bindir"
echo " sysconfdir $sysconfdir"
+echo "#define CONFIGURE_STRING \"$@\"" > configure_params.h