summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2013-05-03 02:07:02 -0700
committerJay Sorg <jay.sorg@gmail.com>2013-05-03 02:07:02 -0700
commit64fabbad687aed9a51357a39e284643d77675a04 (patch)
tree926fc52b92affa7a4455376adb8983266c8afc00 /configure.ac
parent862ee8b914f30e9aac61e33af71b2b071ec9f606 (diff)
downloadxrdp-proprietary-64fabbad687aed9a51357a39e284643d77675a04.tar.gz
xrdp-proprietary-64fabbad687aed9a51357a39e284643d77675a04.zip
got neutrinordp module building
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 52a44b3c..92655612 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,10 @@ AC_ARG_ENABLE(freerdp1, AS_HELP_STRING([--enable-freerdp1],
[Build freerdp1 module (default: no)]),
[freerdp1=true], [freerdp1=false])
AM_CONDITIONAL(XRDP_FREERDP1, [test x$freerdp1 = xtrue])
+AC_ARG_ENABLE(neutrinordp, AS_HELP_STRING([--enable-neutrinordp],
+ [Build neutrinordp module (default: no)]),
+ [neutrinordp=true], [neutrinordp=false])
+AM_CONDITIONAL(XRDP_NEUTRINORDP, [test x$neutrinordp = xtrue])
AC_ARG_ENABLE(jpeg, AS_HELP_STRING([--enable-jpeg],
[Build jpeg module (default: no)]),
[jpeg=true], [jpeg=false])
@@ -81,6 +85,8 @@ fi
AS_IF( [test "x$enable_freerdp1" = "xyes"] , [PKG_CHECK_MODULES(FREERDP, freerdp >= 1.0.0)] )
+AS_IF( [test "x$enable_neutrinordp" = "xyes"] , [PKG_CHECK_MODULES(FREERDP, freerdp >= 1.0.0)] )
+
# checking for libjpeg
if ! test -z "$enable_jpeg"
then
@@ -123,6 +129,7 @@ AC_CONFIG_FILES([Makefile
xup/Makefile
mc/Makefile
freerdp1/Makefile
+ neutrinordp/Makefile
xrdp/Makefile
sesman/Makefile
sesman/libscp/Makefile