summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-12-20 10:38:04 -0800
committerPavel Roskin <plroskin@gmail.com>2016-12-20 13:07:45 -0800
commit914cdcfee2c55d5c81df92d55fcde21160fdd4eb (patch)
tree64986f96e59e76d97737e2aceb130c70a2233010 /configure.ac
parent634aa1096f5cd95b9d2b82a6461c8030269bf65e (diff)
downloadxrdp-proprietary-914cdcfee2c55d5c81df92d55fcde21160fdd4eb.tar.gz
xrdp-proprietary-914cdcfee2c55d5c81df92d55fcde21160fdd4eb.zip
Don't fail without working nasm if rfxcodec is not enabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4168c1b9..f77c5145 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,6 +125,12 @@ AC_ARG_ENABLE(painter, AS_HELP_STRING([--enable-painter],
[], [enable_painter=no])
AM_CONDITIONAL(XRDP_PAINTER, [test x$enable_painter = xyes])
+# Don't fail without working nasm if rfxcodec is not enabled
+if test "x$enable_rfxcodec" != xyes; then
+ with_simd=no
+ export with_simd
+fi
+
# Check if -ldl is needed to use dlopen()
DLOPEN_LIBS=
AC_CHECK_FUNC(dlopen, [],