summaryrefslogtreecommitdiffstats
path: root/libxrdp/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-10-17 10:33:28 -0700
committerPavel Roskin <plroskin@gmail.com>2016-10-20 10:43:02 -0700
commit0422734fc77bdff2c65df14f27b0fd0400775b23 (patch)
treebe59ff10236e777ef83e5d27fe91e7933661296f /libxrdp/Makefile.am
parent85e98d211a4cad94ebcd87c91966c8f30e4e0b9d (diff)
downloadxrdp-proprietary-0422734fc77bdff2c65df14f27b0fd0400775b23.tar.gz
xrdp-proprietary-0422734fc77bdff2c65df14f27b0fd0400775b23.zip
Merge EXTRA_DEFINES and EXTRA_INCLUDES into AM_CPPFLAGS
AM_CPPFLAGS is a documented Automake variable for C preprocessor flags that should not be overridden when compiling the package. There is no need to have two additional variables that are ultimately merged into AM_CPPFLAGS. Their names are also confusing. EXTDA_DIST is a documented Automake variable. Everything else that starts with "EXTRA" is not.
Diffstat (limited to 'libxrdp/Makefile.am')
-rw-r--r--libxrdp/Makefile.am29
1 files changed, 12 insertions, 17 deletions
diff --git a/libxrdp/Makefile.am b/libxrdp/Makefile.am
index d1c37fb0..e9c63afb 100644
--- a/libxrdp/Makefile.am
+++ b/libxrdp/Makefile.am
@@ -1,40 +1,35 @@
-EXTRA_DEFINES =
-EXTRA_INCLUDES =
EXTRA_LIBS =
EXTRA_FLAGS =
+AM_CPPFLAGS = \
+ -DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
+ -DXRDP_SBIN_PATH=\"${sbindir}\" \
+ -DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
+ -DXRDP_PID_PATH=\"${localstatedir}/run\" \
+ -I$(top_srcdir)/common
+
if XRDP_DEBUG
-EXTRA_DEFINES += -DXRDP_DEBUG
+AM_CPPFLAGS += -DXRDP_DEBUG
else
-EXTRA_DEFINES += -DXRDP_NODEBUG
+AM_CPPFLAGS += -DXRDP_NODEBUG
endif
if XRDP_NEUTRINORDP
-EXTRA_DEFINES += -DXRDP_NEUTRINORDP
+AM_CPPFLAGS += -DXRDP_NEUTRINORDP
EXTRA_LIBS += $(FREERDP_LIBS)
endif
if XRDP_TJPEG
-EXTRA_DEFINES += -DXRDP_JPEG -DXRDP_TJPEG
-EXTRA_INCLUDES += @TurboJpegIncDir@
+AM_CPPFLAGS += -DXRDP_JPEG -DXRDP_TJPEG @TurboJpegIncDir@
EXTRA_FLAGS += @TurboJpegLibDir@
EXTRA_LIBS += -lturbojpeg
else
if XRDP_JPEG
-EXTRA_DEFINES += -DXRDP_JPEG
+AM_CPPFLAGS += -DXRDP_JPEG
EXTRA_LIBS += -ljpeg
endif
endif
-AM_CPPFLAGS = \
- -DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
- -DXRDP_SBIN_PATH=\"${sbindir}\" \
- -DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
- -DXRDP_PID_PATH=\"${localstatedir}/run\" \
- $(EXTRA_DEFINES) \
- -I$(top_srcdir)/common \
- $(EXTRA_INCLUDES)
-
module_LTLIBRARIES = \
libxrdp.la