summaryrefslogtreecommitdiffstats
path: root/libxrdp/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-01-29 22:45:00 -0800
committerPavel Roskin <plroskin@gmail.com>2016-01-29 22:45:00 -0800
commita452d8d36aafda4a873f8c035a3fe3fd51fabd96 (patch)
tree17ce42f7a222d165308585f6d8be3e205a5e95f0 /libxrdp/Makefile.am
parent309fca35acfeb776a422d6140ddae8be0b1dbff0 (diff)
downloadxrdp-proprietary-a452d8d36aafda4a873f8c035a3fe3fd51fabd96.tar.gz
xrdp-proprietary-a452d8d36aafda4a873f8c035a3fe3fd51fabd96.zip
Merge AM_CFLAGS and INCLUDES info AM_CPPFLAGS
AM_CPPFLAGS is for flags passed to the preprocessor, such as defines and includes. AM_CFLAGS is for flags affecting the compiler, such as debug and optimization settings. INCLUDES is an obsolete name. Users can pass INCLUDES and break compilation. AM_CPPFLAGS is more explicit that the flags come from Automake and should not be overridden.
Diffstat (limited to 'libxrdp/Makefile.am')
-rw-r--r--libxrdp/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/libxrdp/Makefile.am b/libxrdp/Makefile.am
index 5435343b..5b89b0c3 100644
--- a/libxrdp/Makefile.am
+++ b/libxrdp/Makefile.am
@@ -28,14 +28,12 @@ EXTRA_LIBS += -ljpeg
endif
endif
-AM_CFLAGS = \
+AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
-DXRDP_PID_PATH=\"${localstatedir}/run\" \
- $(EXTRA_DEFINES)
-
-INCLUDES = \
+ $(EXTRA_DEFINES) \
-I$(top_srcdir)/common \
$(EXTRA_INCLUDES)