summaryrefslogtreecommitdiffstats
path: root/sesman/chansrv/Makefile.am
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2015-01-09 23:31:28 -0800
committerJay Sorg <jay.sorg@gmail.com>2015-01-09 23:31:28 -0800
commit2f5b84b71273f942023259d64b27ddd6f4625046 (patch)
treecfd85619c39c335560df3c2d3c895601a5fc4bee /sesman/chansrv/Makefile.am
parent46215e36d116aeb506bd142df46de1aa0a95e5bd (diff)
downloadxrdp-proprietary-2f5b84b71273f942023259d64b27ddd6f4625046.tar.gz
xrdp-proprietary-2f5b84b71273f942023259d64b27ddd6f4625046.zip
chansrv: added opus audio compression for playback
Diffstat (limited to 'sesman/chansrv/Makefile.am')
-rw-r--r--sesman/chansrv/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/sesman/chansrv/Makefile.am b/sesman/chansrv/Makefile.am
index 7a97c136..ed55ae02 100644
--- a/sesman/chansrv/Makefile.am
+++ b/sesman/chansrv/Makefile.am
@@ -22,6 +22,11 @@ EXTRA_DEFINES += -DXRDP_FUSE
EXTRA_LIBS += -lfuse
endif
+if XRDP_OPUS
+EXTRA_DEFINES += -DXRDP_OPUS
+EXTRA_LIBS += -lopus
+endif
+
AM_CFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \