summaryrefslogtreecommitdiffstats
path: root/sesman/tools/Makefile.am
diff options
context:
space:
mode:
authorspeidy <speidy@gmail.com>2016-12-22 12:04:29 -0500
committerspeidy <speidy@gmail.com>2016-12-22 12:04:29 -0500
commit93c55e58a884270850794c29bd0f4e2df22e22d6 (patch)
tree0eeece185f648a2ddf14d522c54c75c70986afda /sesman/tools/Makefile.am
parentf4224615c97668236826d115fa37b6ce805bea96 (diff)
parent38253f1371b5e01e05ba995f28b6451ee57b613c (diff)
downloadxrdp-proprietary-93c55e58a884270850794c29bd0f4e2df22e22d6.tar.gz
xrdp-proprietary-93c55e58a884270850794c29bd0f4e2df22e22d6.zip
Merge branch 'devel' of https://github.com/neutrinolabs/xrdp
Conflicts: xorgxrdp
Diffstat (limited to 'sesman/tools/Makefile.am')
-rw-r--r--sesman/tools/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/sesman/tools/Makefile.am b/sesman/tools/Makefile.am
index 140c6820..44bf068b 100644
--- a/sesman/tools/Makefile.am
+++ b/sesman/tools/Makefile.am
@@ -1,16 +1,14 @@
-EXTRA_DIST = tcp.h
-
-AM_CFLAGS = \
+AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
- -DXRDP_PID_PATH=\"${localstatedir}/run\"
-
-INCLUDES = \
+ -DXRDP_PID_PATH=\"${localstatedir}/run\" \
-I$(top_srcdir)/common \
-I$(top_srcdir)/sesman/libscp \
-I$(top_srcdir)/sesman
+AM_CFLAGS = $(X_CFLAGS)
+
bin_PROGRAMS = \
xrdp-sesrun \
xrdp-sesadmin \
@@ -21,9 +19,10 @@ noinst_PROGRAMS = \
xrdp-xcon
xrdp_sesrun_SOURCES = \
+ config.c \
sesrun.c \
tcp.c \
- config.c
+ tcp.h
xrdp_sestest_SOURCES = \
sestest.c
@@ -48,6 +47,8 @@ xrdp_sesadmin_LDADD = \
$(top_builddir)/common/libcommon.la \
$(top_builddir)/sesman/libscp/libscp.la
+xrdp_xcon_LDFLAGS = \
+ $(X_LIBS)
+
xrdp_xcon_LDADD = \
- -L/usr/X11R6/lib \
- -lX11
+ $(X_PRE_LIBS) -lX11 $(X_EXTRA_LIBS)