summaryrefslogtreecommitdiffstats
path: root/xrdpapi/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2017-03-14 21:45:50 -0700
committerjsorg71 <jay.sorg@gmail.com>2017-03-17 22:25:05 -0700
commit58c9cb43e9e83a6f5cc8a13cd84aa67cce8cacd5 (patch)
tree4440da8a15401e221175c4b6d3df6c44253e3f2e /xrdpapi/Makefile.am
parentfc2572f60b574cf5bc45f1c7b58698681f39ac50 (diff)
downloadxrdp-proprietary-58c9cb43e9e83a6f5cc8a13cd84aa67cce8cacd5.tar.gz
xrdp-proprietary-58c9cb43e9e83a6f5cc8a13cd84aa67cce8cacd5.zip
Make socket directory configurable, don't hardcode /tmp/.xrdp
Use XRDP_SOCKET_PATH in file_loc.h Don't define any non-socket paths in file_loc.h, they should come from the makefiles. Define all paths unconditionally, they should not be defined elsewhere. Pass XRDP_SOCKET_PATH as environment variable to the backends.
Diffstat (limited to 'xrdpapi/Makefile.am')
-rw-r--r--xrdpapi/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/xrdpapi/Makefile.am b/xrdpapi/Makefile.am
index fefa03fc..d40109a9 100644
--- a/xrdpapi/Makefile.am
+++ b/xrdpapi/Makefile.am
@@ -3,6 +3,10 @@ EXTRA_DIST = \
vrplayer.c \
vrplayer.mk
+AM_CPPFLAGS = \
+ -DXRDP_SOCKET_PATH=\"${socketdir}\" \
+ -I$(top_srcdir)/common
+
module_LTLIBRARIES = \
libxrdpapi.la