summaryrefslogtreecommitdiffstats
path: root/instfiles/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'instfiles/Makefile.am')
-rw-r--r--instfiles/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/instfiles/Makefile.am b/instfiles/Makefile.am
index 505ddf30..8f8616c5 100644
--- a/instfiles/Makefile.am
+++ b/instfiles/Makefile.am
@@ -6,3 +6,10 @@ startscriptdir=$(sysconfdir)/xrdp
startscript_DATA = \
xrdp.sh
+
+# must be tab below
+install-data-hook:
+ chmod 755 $(DESTDIR)$(sysconfdir)/xrdp/xrdp.sh
+ if [ -w /etc/init.d ]; then rm -f /etc/init.d/xrdp.sh; fi
+ if [ -w /etc/init.d ]; then $(LN_S) $(DESTDIR)$(sysconfdir)/xrdp/xrdp.sh /etc/init.d/xrdp.sh; fi
+ $(DESTDIR)$(bindir)/xrdp-keygen xrdp $(DESTDIR)$(sysconfdir)/xrdp/rsakeys.ini