summaryrefslogtreecommitdiffstats
path: root/keygen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'keygen/Makefile.am')
-rw-r--r--keygen/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/keygen/Makefile.am b/keygen/Makefile.am
index ffe6d956..8cdea746 100644
--- a/keygen/Makefile.am
+++ b/keygen/Makefile.am
@@ -18,7 +18,8 @@ xrdpsysconfdir = $(sysconfdir)/xrdp
install-data-hook:
umask 077 && \
- if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini ]; then ./xrdp-keygen xrdp $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini; fi
+ if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini ]; then ./xrdp-keygen xrdp $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini; fi && \
+ if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/cert.pem ]; then openssl req -x509 -newkey rsa:2048 -nodes -keyout $(DESTDIR)$(xrdpsysconfdir)/key.pem -out $(DESTDIR)$(xrdpsysconfdir)/cert.pem -days 365 -subj /C=US/ST=CA/L=Sunnyvale/O=xrdp/CN=www.xrdp.org; fi
uninstall-hook:
rm -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini