summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-01-22 02:06:59 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-01-22 02:07:14 +0100
commitbdd067370eb0af9b2e8179034730ef8e9e4c8202 (patch)
tree0b7304300b0bca945ff7f4ea0d88f9152eebed5b /src/Makefile.am
parent8555e787224b828035787e04206fbb8affe6262e (diff)
downloadksensors-bdd067370eb0af9b2e8179034730ef8e9e4c8202.tar.gz
ksensors-bdd067370eb0af9b2e8179034730ef8e9e4c8202.zip
Strictly use autostart-enabled .desktop
This resolves Bug 2577 Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit b62b2d3a077be091b693fecb52f65cbc1ac2681e)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8128f46..7c17c10 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,10 +45,14 @@ ksensors_SOURCES = main.cpp ksensors.cpp aboutcfgdesign.ui \
ksensors_LDFLAGS = $(TDE_RPATH) $(all_libraries)
ksensors_LDADD = $(LIB_TDEUI) $(LIB_TDECORE) $(LIB_QT) -lsensors -lm
-# this is where the desktop file will go
+# this is where the desktop file will go
shelldesktopdir = $(kde_appsdir)/System
shelldesktop_DATA = ksensors.desktop
+# and for autostart
+autostartdir = $(prefix)/share/autostart
+autostart_DATA = ksensors.desktop
+
# this is where the shell's XML-GUI resource file goes
shellrcdir = $(kde_datadir)/ksensors
shellrc_DATA = ksensorsui.rc