summaryrefslogtreecommitdiffstats
path: root/src/themes/FingerPrint/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-03 02:39:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-03 02:39:22 +0200
commit460b0273772f313ff533ba655ccaa11cf7acef5c (patch)
tree9ee16960767f394dd426921f86ae1a710301772d /src/themes/FingerPrint/CMakeLists.txt
parent51efb685369b4126eeb67225b7a775f9bc2ad66d (diff)
downloadksplash-engine-moodin-460b0273772f313ff533ba655ccaa11cf7acef5c.tar.gz
ksplash-engine-moodin-460b0273772f313ff533ba655ccaa11cf7acef5c.zip
Add the ability to translate:
+ Catalog for strings in the plugin. + Desktop file translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/themes/FingerPrint/CMakeLists.txt')
-rw-r--r--src/themes/FingerPrint/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/themes/FingerPrint/CMakeLists.txt b/src/themes/FingerPrint/CMakeLists.txt
index cfcad13..fa5afec 100644
--- a/src/themes/FingerPrint/CMakeLists.txt
+++ b/src/themes/FingerPrint/CMakeLists.txt
@@ -1,6 +1,13 @@
-file( GLOB _pics RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.png )
+file( GLOB _pics RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.png *.jpg )
install(
- FILES ${_pics} Background.jpg Theme.rc
+ FILES ${_pics}
DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/FingerPrint
)
+
+tde_create_translated_desktop(
+ SOURCE Theme.rc
+ KEYWORDS Label1 Label2 Label3 Label4 Label5
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/FingerPrint
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/themes
+)