summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild')
-rw-r--r--trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild b/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild
new file mode 100644
index 00000000..96fa4e9b
--- /dev/null
+++ b/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+TRINITY_MODULE_TYPE="core"
+TRINITY_SUBMODULE="wizards"
+
+inherit trinity-meta-2
+
+DESCRIPTION="TDEPIM wizards"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/knotes-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/tdepim-tderesources-${PV}"
+RDEPEND="${DEPEND}"
+
+TSM_EXTRACT_ALSO="libtdepim/ tderesources/ kmail/ libkpimidentities/ knotes/ libkcal/ \
+ libemailfunctions/ translations/"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_FLAGS="-L${TDEDIR}/$(get_libdir)"
+ -DWITH_EGROUPWARE=ON
+ -DWITH_KOLAB=ON
+ -DWITH_SLOX=ON
+ -DWITH_GROUPWISE=ON
+ -DWITH_NEWEXCHANGE=ON
+ -DWITH_SCALIX=ON
+ )
+ trinity-meta-2_src_configure
+}