summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--media-libs/jasper/jasper-2.0.16.ebuild6
-rw-r--r--media-libs/jasper/jasper-9999.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/jasper/jasper-2.0.16.ebuild b/media-libs/jasper/jasper-2.0.16.ebuild
index 7712bb0c..ad71ee56 100644
--- a/media-libs/jasper/jasper-2.0.16.ebuild
+++ b/media-libs/jasper/jasper-2.0.16.ebuild
@@ -2,8 +2,8 @@
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-
+EAPI="8"
+CMAKE_ECLASS="cmake"
inherit cmake-multilib
DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
@@ -69,5 +69,5 @@ multilib_src_configure() {
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/jasper/jasper-9999.ebuild b/media-libs/jasper/jasper-9999.ebuild
index 5edec112..00b3c634 100644
--- a/media-libs/jasper/jasper-9999.ebuild
+++ b/media-libs/jasper/jasper-9999.ebuild
@@ -3,7 +3,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-
+CMAKE_ECLASS="cmake"
inherit cmake-multilib
DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
@@ -62,5 +62,5 @@ multilib_src_configure() {
# Doxygen
-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
)
- cmake-utils_src_configure
+ cmake_src_configure
}