summaryrefslogtreecommitdiffstats
path: root/kate/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-15 20:12:47 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-16 14:56:12 +0200
commite604ddcc4c22f4baa33b3ac7737271346c5b33c8 (patch)
tree5801d6f9c361d087b54fff6d554d02c91befcb57 /kate/CMakeLists.txt
parent02e3da597ed8db74f0a8e8866682d4549da9fbd0 (diff)
downloadtdeaddons-e604ddcc4c22f4baa33b3ac7737271346c5b33c8.tar.gz
tdeaddons-e604ddcc4c22f4baa33b3ac7737271346c5b33c8.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit cb8cda7bca532df21c02bc4d2bfd03387df7f852)
Diffstat (limited to 'kate/CMakeLists.txt')
-rw-r--r--kate/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/kate/CMakeLists.txt b/kate/CMakeLists.txt
index 1506c26..46a42e4 100644
--- a/kate/CMakeLists.txt
+++ b/kate/CMakeLists.txt
@@ -31,4 +31,8 @@ add_subdirectory( katesort )
#### other data #################################
-install( FILES kate-plugins.desktop DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+tde_create_translated_desktop(
+ SOURCE kate-plugins.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR kate-plugins-desktops
+)